Firefox 1.5 Beta 2 released

Firefox 1.5 Beta 2 has been released. If you downloaded the Windows build from the last post, or the Mac or Linux build from two posts ago, you already have it.

What's new in Firefox 1.5 Beta 2

5 Responses to “Firefox 1.5 Beta 2 released”

  1. Ferdinand Says:

    So why can’t you update from Firefox 1.5 Beta 1 to 2? I keep checking but it finds nothing.

  2. Ferdinand Says:

    Oh I’m sorry: “If you’re a Beta 1 user, you should wait for the automatic update to be triggered sometime in the next few days so we can get more testing on that. The incremental update from Beta 1 to Beta 2 is 700K which is really nice.”

  3. jamcnair Says:

    Beta 2 is live on Mozilla update. Showed up as “Firefox 1.4.1”.Patch size for me was 782 kB. So far, no problems, though a few of my themes need a point compatibility update methinks. YAY! Extension manager is scrollable again (wasn’t in beta 1)!!

    Good to also see more extensions getting updated.

    SVG on cairo is a little slower for things, a little faster for other things, still nice. I hope they’ll continue to backport newer cairo versions to the 1.8 branch, since cairo is (I think) independent of thebes (the C++ framework on top of cairo?). I mean, the improvements are worth it.

    Mind you, I understand not backporting new SVG features (though that would be wonderful, especially animation and WORKING foreignObject), but faster/bugfixed cairo is good for all I think.

    Thanks to you, and all the others for the hard work.

  4. kendo Says:

    I’ve noticed some problems in Firefox 1.5 Beta 2. After opening a group of 5 tabs, the Find functionality breaks. It works for the first tab, but not others. Also, if I type in a search term in the location field (e.g. “keyword:apple”) and then switch to another tab, the location field does not display the URL of the page you’re viewing. I reverted back to 1.5 Beta 1 and everything I mentioned above work just fine.

    Anyone else experiencing this with Beta 2?

  5. Bren Says:

    Kendo writes:

    After opening a group of 5 tabs, the Find functionality breaks.

    I’ve noticed this as well. I couldn’t find an open bug report for this yet. Starting a new bug is so tedious. :(