2005-08-31 Branch builds

New stuff:

  • Fixed: 302103 - Implement SVG events.


  • Fixed: 304499 - Bookmark all Tabs menuitem not properly enabled / disabled.

Fixes for regressions:

  • Fixed: 306304 - If bookmarks.bak is missing, all bookmarks are overwritten by the default bookmarks.
  • Fixed: 305959 - View Source displays a cached page after post submit instead of new page.
  • Fixed: 306382 - Components.utils.evalInSandbox can fail silently.
  • Fixed: 306467 - Automatic proxy configuration URL doesn't work (since Aug 30).
  • Fixed: 304643 - [Mac] Font used in Preferences dialog is too small.

Fixes for security holes:

  • Fixed: 263182 - Page Info (Security tab) doesn't explain mixed secure/insecure.
  • Fixed: 302276 - Flip xpcnativewrappers default to yes. (This fixes security holes in many extensions, but also breaks some extensions.)

No major regressions since Deer Park Alpha 2.

Gecko 1.8 branch checkins between 2005-08-30 06:00 and 2005-08-31 06:00

Windows builds: Windows nightly, Windows hourly (discussion)

Linux builds: Linux nightly, Linux hourly

Mac builds: Mac nightly, Mac hourly

4 Responses to “2005-08-31 Branch builds”

  1. Adam Says:

    Anyone else see several of the Preferences below the bottom edge of the (unresizable) window under OS X? For instance the “Fonts and Colors” options under the “Content” section and “Languages” under the “Advanced->General” section. Not sure if this is my OS X theme (Milk) or if it happens to others.

  2. Ishan Bhattacharya Says:

    I have the same problem as Adams’s for at least the last five daily builds, e.g., clicking on “Bookmark this page” generates a screeen-filling grey sheet in which the OK and Cancel buttons are not visible, clicking on the “close” button doesn’t work and I have to hit “esc” to get rid of the sheet, which then rolls up in a peculiarly asymmetric slow way. This is not due to any themes/extensions for Deerpark or OS X themes. It occurs on OS X 10.4.2 and latest beta of 10.4.3. I have deleted the entire Firefox folder in “Application Support” in my home directory and the problem still happens. Any thoughts welcome.

  3. Boby Dimitrov Says:

    Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050831 Firefox/1.0+

    I am not able to close the first tab. Nor ctrl+w, nor red X on the tabbar works. Is this a known bug?

    Also, Webdev toolbar shows empty – no icons, no text, etc. But it works – edit css, validation, stuff that can be run with shortcuts. Any idea how to get that fixed?

  4. Ross Shannon Says:

    Yeah, something has broken the Chatzilla extension recently too.