2006-06-01 Trunk builds


  • Fixed: 252362 - Security warning preferences should be exposed in user interface.
  • Fixed: 279687 - Should be able to open new tab by middle-clicking "Go" button.
  • Fixed: 240095 - Location Bar dropdown doesn't stay open (collapses) when clicking on arrow the first time.
  • Fixed: 290255 - Slider Tag, <scale>.
  • Fixed: 311015 - Safe mode: add support for disabling all extensions.
  • Fixed: 315402 - Create Accessibility section in Help Documentation.
  • Fixed: 325913 - Allow keyword search to have a parameter and non-parameter url.
  • Fixed: 339695 - [Mac] New version of Java Embedding Plugin (0.9.5+e).

Fixes for recent regressions:

  • Fixed: 339482 - [Mac] Window loses focus, no keyboard input accepted.
  • Fixed: 337117 - [Windows] Browser crashes when opening saunalahti.fi or maps.google.com [@ fbRasterizeEdges8].
  • Fixed: 337424 - Unloaded part of image drawn as black when top of image is above visible region.

Trunk regressions:

  • Since VC8/Cairo: 329237 - [Windows] Firefox uninstaller fails.
  • Since Cairo: 330715 - Cairo incorrectly substitutes fonts and then bolds them incorrectly (incorrect fonts on Burning Edge bug lists).
  • Since Cairo: 324707 - Animated GIFs leave trails / don't erase in Cairo.
  • Since Cairo: 324706 - Bitmap fonts don't render in cairo builds.
  • Since Cairo: 324560 - Can't see many Unicode characters in Cairo.
  • Since Jan 26 (FDL): [Mac] Opacity doesn't work. (Related to 325296. Cairo will fix.)
  • Since Jan 26 (FDL): 324819 - Fixed positioned elements now lag/flicker when scrolling.
  • Since Jan 26 (FDL): 324963 - [Windows] Menu highlight is broken/doesn't show up/not painted.

Trunk checkins between 2006-05-26 06:00 and 2006-06-01 06:00

Windows builds: Windows nightly, Windows hourly (discussion)

Linux builds: Linux nightly Linux hourly

Mac builds: Mac nightly, Mac hourly

4 Responses to “2006-06-01 Trunk builds”

  1. Uri Bernstein Says:

    You might want to add Bug 339327 to the list of trunk regressions.

  2. Allan Says:

    I’m having trouble getting extensions to be compatible with the latest trunk builds. I’ve set app.extensions.version to 1.0+ but that didn’t do anything. Then I tried Nightly Tester Tools but the make compatible button doesn’t do anything.

    Any suggestions?

  3. Jesse Ruderman Says:

    Allan, that’s probably related to the changes from https://bugzilla.mozilla.org/show_bug.cgi?id=330895. Try setting the new boolean pref extensions.checkCompatibility to false.

  4. Allan Says:

    Thanks, that worked great.