2004-08-03 Branch builds

  • Fixed: 253757 - Submenus of context menu don't open automatically (since ~July 30).
  • Fixed: 234700 - Deleting history entry doesn't remove it from history.dat.
  • Fixed: 217640 - Autocomplete removes exactly matching entries from list.
  • Fixed: 253782 - Extremely large transparent PNG images crash.
  • Fixed: 248982 - Add Tell a Friend and Promote Firefox items to Help menu. The content itself is not yet live on the site and won't be until PR1.
  • Fixed: 214968 - .bmp extension should be listed in Open File options.
  • Since July 30: 253709 - Search bar autocomplete pops up near left-top of screen after clicking on elements in a site.
  • Since July 27: 253288 - [WindowsXP with Luna] At secure sites, the Lock icon is missing from the status bar.
  • Since ~July 23: 254040 - Incorrect address in address bar after typing phrase for I'm Feeling Lucky Google search.

Windows builds: Official Windows, Official Windows installer (discussion)

Linux builds: Official Linux, Official Linux installer, lokean's with SVG

Mac builds: No official Mac build.

3 Responses to “2004-08-03 Branch builds”

  1. Freyr Says:

    Cookies will not save for me in the lastest few nightly’s.Yesterday I needed to make a new profile for the july 30 release but thought it might be a known bug and be fix on the next linux nightly.Cookies where working before,I made a new profile.

    Exceptions and View cookies are always empty when I start firefox.
    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040730 Firefox/0.9.1+
    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.1+

  2. alepp Says:

    Yes, there’s something very different with cookie handling. On 07-25 it was all normal. I then installed 07-30 (cookies.txt read-only, as for previous umpteen years) and it started creating cookies-1.txt, cookies-2.txt, etc… starting with cookies.txt.moztmp too. It also removed my write-protection on the original cookies.txt

    I put up a Topic on this, but only got one response:
    http://forums.mozillazine.org/viewtopic.php?t=108866

    I can see that you (Freyr) also ran into another more recent Topic:
    http://forums.mozillazine.org/viewtopic.php?t=109335

  3. Josť Jeria Says:

    Bug 231393 still dont work for me, when clicking on a link in an external application, the url is not prefilled, and if the server does not reply, you never see what link you clicked on.

    Anyone else seing this?