2004-05-07 Trunk builds

In the 7 days since my last Burning Edge post, all of the regressions I had been tracking here, plus a few more, have been fixed!

  • Fixed: 241068 - Intermittent crash when entering text in input field. (Since ~Apr 17)
  • Fixed: 238186 - URL in Page Info dialog appears blue. (Since Mar 20)
  • Fixed: 241700 - alt+spacebar must be pressed twice to activate Windows control menu (since ~Apr 22)
  • Fixed: 242082 - Help Viewer TOC topic-loading broken on 20040428
  • Fixed: 240962 - Charset in Content-Type header is ignored for XHTML
  • Fixed (?): 239366 - Official gtk2 build crashes on startup on Fedora Core 1 (Since ~Mar 28).
  • Fixed: Green square in status bar (Since ~Apr 30).

Many additional bugs have been fixed and features added:

  • Fixed: 123662 - "File / cannot be found. Please check the location and try again" when loading page
  • Fixed: 203756 - Enable URLBar autofill with hidden pref "browser.urlbar.autoFill"
  • Fixed: 236313 - Mozilla crashes after clicking "SKYPASS" at Korean Air site
  • Fixed: 242282 - M17rc1 crash quickly hitting back button [@ nsPluginDOMContextMenuListener::Destroy]
  • Fixed: 230417 - M17b crash [@ 0x00000000 - nsIView::Destroy] - Print preview crashes at http://www.linuxworld.com/story/32629.htm
  • Fixed: 242564 - Default p3p cookie action changed to reject
  • Fixed: 242069 - "Manage Security Devices" and "Manage Certificates" does not work (error "openDeviceManager is not defined" etc. shown in Javascript Console)
  • Fixed: 158071 - Input undo/redo buffers cleared after Javascript changes to input values
  • Fixed: 241592 - page with flash object and unsized image never finishes loading
  • Fixed: 57906 - :root element grows to fit contents [BG] (stretches)
  • Fixed: 60212 - Add DOM 2 UIEvent interface
  • Fixed: 212177 - Pasting selections containing images as text doesn't include alt text
  • Fixed: 242503 - selectbox options are redendered as text outside of the selectbox
  • Fixed: 97434 - Some Windows keyboard behaviours missing from trees
  • Fixed: 217916 - advanced options: expanding/collapsing bugs

But there are several new major regressions:

  • Since May 6: 242856 - Slow image rendering.
  • Since ~May 4: 242691 - Animated gifs do not animate properly.
  • Since May 1: 242709 - Disabling Submit button prevents form from submitting.
  • Since May 1: 242439 - submit button on planet.nl does not work.
  • Since ~Apr 30: 242275 - browser window hangs on https certificate dialog (installer builds only).
  • Since ~Apr 26: 241865 - Drag-n-drop link to download manager doesn't work.

Windows builds: Official Windows, Official Windows installer (discussion), moox's experimental build, BlueFyre's O2 G7 SSE, bangbang's O2 G7 SSE2, Lohvarn's builds, dbright's builds, djeter's O2 G7 SSE2 and O2 G6 SSE, TierMann's O2 G7 SSE, O2 G6

Lohvarn made branch builds in addition to trunk builds.

Linux builds: Official Linux, no official gtk2+xft builds, daihard's SSE2, MozJF's gtk2+xft

Mac builds: Official Mac

9 Responses to “2004-05-07 Trunk builds”

  1. fishbert Says:

    I’d argue this should be listed among the regressions (in big, flashing letters).
    http://bugzilla.mozilla.org/show_bug.cgi?id=239722

  2. Anonymous Says:

    LMAO, that is awesome…

  3. berkut Says:

    I know of slow image rendering: sometimes the image renders for down up, but there another bug that’s =very annoying and pretty serious:

    on all build 20040506 sometimes the whole page or part of page don’t render, stay white, only scrolling up and down makes them render all the way.

  4. Josť Jeria Says:

    Anyone else noticed that ctrl + – doesnt work for making text smaller? works with the – on the keypad though.

  5. Jesse Ruderman Says:

    berkut: After using this build for a few hours, I started hitting a problem where the page would go white 0.2s after loading and remain white for 1s. It’s not exactly what you describe but it could be the same bug.

    Jose: WFM

  6. Patrick Sarnowski Says:

    While the list of fixes is great, the regressions are serious enough to not go near these recent nightlies except to help troubleshoot IMHO.

  7. Josť Jeria Says:

    I noticed that it works if i press ctrl + 0…
    This is weird, maybe because i have a swedish keyboard (also set to swedish)?

  8. djengis Says:

    ctrl + should have been fixed 6/5…
    http://bugzilla.mozilla.org/show_bug.cgi?id=238474

  9. Josť Jeria Says:

    djengis: Yeah, for view source it was.